注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

成功源于细节

梦想、奋斗、收获

 
 
 

日志

 
 
 
 

php_openssl.dll' - 找不到指定的模块。 in Unknown on line 0  

2013-04-17 12:56:29|  分类: php |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
  今天在windows2003配置IIS+php_openssl,php-error.log老是提示“PHPWarning:PHPStartup:Unabletoloaddynamiclibrary'C:\PHP\ext\php_openssl.dll'-找不到指定的模块。inUnknownonline0”

  看了看路径是对的,libeay32.dll和ssleay32.dll也在windows/system32目录下,就是找不到模块,经多次调试搜索,终于找到疑点:

  原来的php包中没有php_openssl.dll文件,我就下载一个php-5.2.17-nts-Win32-VC6-x86.zip,解压复制进去,但原来用的是ThreadSafe包,不会加载noThreadSafe包的扩展的,立即下载php-5.2.17-Win32-VC6-x86,解压复制替换原来的php_openssl.dll,重启IIS,正常运行,不在有找不到模块的提示了。

        总结:php加载扩展提示找不到模块时,首先确认文件存在路径正确,其次还要对应版本和 Thread Safe 

  评论这张
 
阅读(957)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017