注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

成功源于细节

梦想、奋斗、收获

 
 
 

日志

 
 
 
 

nodejs及browser-sync的安装  

2016-01-05 18:06:28|  分类: linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
操作系统:ubuntu 12.04LTS
安装原因:手机前端页面调试
安装过程:browser-sync要求先安装nodejs,所有操作在root权限下;

#curl https://www.npmjs.com/install.sh|sh
#apt-get install npm
#npm install -g browser-sync

出错,

npm ERR! install Couldn't read dependencies 
npm ERR! package.json ENOENT, open '/home/liu/Dev/package.json' 
npm ERR! package.json This is most likely not a problem with npm itself. 
npm ERR! package.json npm can't find a package.json file in your current directory. 

或:

npm ERR! Error: failed to fetch from registry:

找到http://www.myexception.cn/ai/1819874.html

#npm config set registry http://registry.npmjs.org/
#npm install -g browser-sync

还是出错:

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: connect@2.11.0
npm ERR! Required: {"node":">= 0.8.0"}
npm ERR! Actual:   {"npm":"1.1.4","node":"0.6.12"}

找到:http://stackoverflow.com/questions/18562234/npm-install-express-error-no-compatible-version-found

#add-apt-repository ppa:chris-lea/node.js
#apt-get update
#apt-get install nodejs -y

问题解决:

#npm install -g browser-sync

安装成功。

  评论这张
 
阅读(321)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017